using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/{2}.*|\/\*.*\*\/$";
string input = @"<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src=""//google.com"";
</script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}