using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*00.*00)(?!.*11.*11)(?=.*00)(?=.*11)[01]+$";
string input = @"0101010011
0011
010101
10
1001011010101010
10
10101
101011
11010100
1001100000010101010101
010000
01000100
110011
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}