import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*00.*00)(?!.*11.*11)(?=.*00)(?=.*11)[01]+$";
final String string = "0101010011\n"
+ "0011\n"
+ "010101\n"
+ "10\n"
+ "1001011010101010\n"
+ "10\n"
+ "10101\n"
+ "101011\n"
+ "11010100\n"
+ "1001100000010101010101\n\n\n"
+ "010000\n"
+ "01000100\n\n"
+ "110011\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}