$re = '/^(?!.*00.*00)(?!.*11.*11)(?=.*00)(?=.*11)[01]+$/m';
$str = '0101010011
0011
010101
10
1001011010101010
10
10101
101011
11010100
1001100000010101010101
010000
01000100
110011
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);