import re
regex = re.compile(r"^(?!.*00.*00)(?!.*11.*11)(?=.*00)(?=.*11)[01]+$", flags=re.MULTILINE)
test_str = ("0101010011\n"
"0011\n"
"010101\n"
"10\n"
"1001011010101010\n"
"10\n"
"10101\n"
"101011\n"
"11010100\n"
"1001100000010101010101\n\n\n"
"010000\n"
"01000100\n\n"
"110011\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")