#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "CREATE TABLE\s+\'([^\']+)[\s\S]+PRIMARY KEY\(([^,]+),([^\)]+)\)"
Local $sString = "CREATE TABLE 'dhcpr_dhcprelayinterface' (" & @CRLF & _
" 'vrId' integer default 0," & @CRLF & _
" 'ifName' string ," & @CRLF & _
" PRIMARY KEY(ifName,vrId)," & @CRLF & _
" FOREIGN KEY (vrId) REFERENCES 'vr_vr'(vrId) ON DELETE CASCADE ON UPDATE CASCADE);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")