$re = '/CREATE TABLE\s+\'([^\']+)[\s\S]+PRIMARY KEY\(([^,]+),([^\)]+)\)/';
$str = 'CREATE TABLE \'dhcpr_dhcprelayinterface\' (
\'vrId\' integer default 0,
\'ifName\' string ,
PRIMARY KEY(ifName,vrId),
FOREIGN KEY (vrId) REFERENCES \'vr_vr\'(vrId) ON DELETE CASCADE ON UPDATE CASCADE);';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);