re = /CREATE TABLE\s+\'([^\']+)[\s\S]+PRIMARY KEY\(([^,]+),([^\)]+)\)/
str = 'CREATE TABLE \'dhcpr_dhcprelayinterface\' (
\'vrId\' integer default 0,
\'ifName\' string ,
PRIMARY KEY(ifName,vrId),
FOREIGN KEY (vrId) REFERENCES \'vr_vr\'(vrId) ON DELETE CASCADE ON UPDATE CASCADE);'
# Print the match result
str.match(re) do |match|
puts match.to_s
end