import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE TABLE\\s+\\'([^\\']+)[\\s\\S]+PRIMARY KEY\\(([^,]+),([^\\)]+)\\)";
final String string = "CREATE TABLE 'dhcpr_dhcprelayinterface' (\n"
+ " 'vrId' integer default 0,\n"
+ " 'ifName' string ,\n"
+ " PRIMARY KEY(ifName,vrId),\n"
+ " FOREIGN KEY (vrId) REFERENCES 'vr_vr'(vrId) ON DELETE CASCADE ON UPDATE CASCADE);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}