$re = '/^.*?(\d+)$/';
$str = '/demoapi/api/user/123';
$subst = "/user/?user=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;