import Foundation
let pattern = #"^.*?(\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/demoapi/api/user/123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/user/?user=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)