re = /^.*?(\d+)$/
str = '/demoapi/api/user/123'
subst = '/user/?user=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result