package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a\b.*?\/>(*SKIP)(*FAIL)|<(\w+).*?>`)
var str = `<sth a="awdawd"/><a href="http://awdwsrrdg.com"/>`
var substitution = "<$1 />"
fmt.Println(re.ReplaceAllString(str, substitution))
}