use strict;
my $str = '<sth a="awdawd"/><a href="http://awdwsrrdg.com"/>';
my $regex = qr/<a\b.*?\/>(*SKIP)(*FAIL)|<(\w+).*?>/p;
my $subst = '<$1 />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";