import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\b.*?\\/>(*SKIP)(*FAIL)|<(\\w+).*?>";
final String string = "<sth a=\"awdawd\"/><a href=\"http://awdwsrrdg.com\"/>";
final String subst = "<$1 />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}