$re = '/<a\b.*?\/>(*SKIP)(*FAIL)|<(\w+).*?>/';
$str = '<sth a="awdawd"/><a href="http://awdwsrrdg.com"/>';
$subst = "<$1 />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;