#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d\s()]+(?: [^\d\s()]+)*"
Local $sString = "Argentina" & @CRLF & _
"Australia1" & @CRLF & _
"Bolivia (Plurinational State of)" & @CRLF & _
"China, Hong Kong Special Administrative Region" & @CRLF & _
"Côte d'Ivoire" & @CRLF & _
"Curaçao" & @CRLF & _
"Guinea-Bissau" & @CRLF & _
"Indonesia8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")