import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d\\s()]+(?: [^\\d\\s()]+)*";
final String string = "Argentina\n"
+ "Australia1\n"
+ "Bolivia (Plurinational State of)\n"
+ "China, Hong Kong Special Administrative Region\n"
+ "Côte d'Ivoire\n"
+ "Curaçao\n"
+ "Guinea-Bissau\n"
+ "Indonesia8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}