package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\d\s()]+(?: [^\d\s()]+)*`)
var str = `Argentina
Australia1
Bolivia (Plurinational State of)
China, Hong Kong Special Administrative Region
Côte d'Ivoire
Curaçao
Guinea-Bissau
Indonesia8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}