$re = '/^[^\d\s()]+(?: [^\d\s()]+)*/m';
$str = 'Argentina
Australia1
Bolivia (Plurinational State of)
China, Hong Kong Special Administrative Region
Côte d\'Ivoire
Curaçao
Guinea-Bissau
Indonesia8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);