re = /^[^\d\s()]+(?: [^\d\s()]+)*/m
str = 'Argentina
Australia1
Bolivia (Plurinational State of)
China, Hong Kong Special Administrative Region
Côte d\'Ivoire
Curaçao
Guinea-Bissau
Indonesia8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end