# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d),(?=\d{3})//g;t' <<< "\"12,345.67\",12.34,\"123,456.78\",1.00,\"123,456,789.12\""