use strict;
my $str = '"12,345.67",12.34,"123,456.78",1.00,"123,456,789.12"';
my $regex = qr/(?<=\d),(?=\d{3})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";