import Foundation
let pattern = #"(?<=\d),(?=\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""12,345.67",12.34,"123,456.78",1.00,"123,456,789.12""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)