using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d),(?=\d{3})";
string substitution = @"";
string input = @"""12,345.67"",12.34,""123,456.78"",1.00,""123,456,789.12""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}