$re = '/(?<=\d),(?=\d{3})/';
$str = '"12,345.67",12.34,"123,456.78",1.00,"123,456,789.12"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;