#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)translate\(" & @CRLF & _
"([\'"]) # capture quote char" & @CRLF & _
"((?:" & @CRLF & _
" (?!\1). # not a quote" & @CRLF & _
"| # or" & @CRLF & _
" \\\1 # escaped one" & @CRLF & _
")* # " & @CRLF & _
"[^\\\\]?)\1 # match unescaped last quote char" & @CRLF & _
"\)"
Local $sString = "translate("some text here")" & @CRLF & _
"translate('some text here')" & @CRLF & _
"translate('"some text here..."')" & @CRLF & _
"translate("a\"b\"c\"d")" & @CRLF & _
"translate("")" & @CRLF & _
"translate("a\"b"c\"d")" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")