// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)translate\(
([\'"]) # capture quote char
((?:
(?!\1). # not a quote
| # or
\\\1 # escaped one
)* #
[^\\\\]?)\1 # match unescaped last quote char
\)"#).unwrap();
let string = "translate(\"some text here\")
translate('some text here')
translate('\"some text here...\"')
translate(\"a\\\"b\\\"c\\\"d\")
translate(\"\")
translate(\"a\\\"b\"c\\\"d\")
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}