$re = '@translate\(
([\'"]) # capture quote char
((?:
(?!\1). # not a quote
| # or
\\\\\1 # escaped one
)* #
[^\\\\\\\\]?)\1 # match unescaped last quote char
\)@x';
$str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate("a\\"b\\"c\\"d")
translate("")
translate("a\\"b"c\\"d")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);