re = /translate\(
([\'"]) # capture quote char
((?:
(?!\1). # not a quote
| # or
\\\1 # escaped one
)* #
[^\\\\]?)\1 # match unescaped last quote char
\)/x
str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate("a\\"b\\"c\\"d")
translate("")
translate("a\\"b"c\\"d")
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end