#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).+@.+.\.\w+"
Local $sString = "nickname" & @CRLF & _
"mail@example.com" & @CRLF & _
"pass" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"nickname2" & @CRLF & _
"mail2@example.com" & @CRLF & _
"pass2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")