re = /.+@.+.\.\w+/i
str = 'nickname
mail@example.com
pass
nickname2
mail2@example.com
pass2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end