using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+@.+.\.\w+";
string input = @"nickname
mail@example.com
pass
nickname2
mail2@example.com
pass2";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}