package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).+@.+.\.\w+`)
var str = `nickname
mail@example.com
pass
nickname2
mail2@example.com
pass2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}