$re = '/.+@.+.\.\w+/i';
$str = 'nickname
mail@example.com
pass
nickname2
mail2@example.com
pass2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);