using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)(\d{1})";
string substitution = @"$1.$2";
string input = @"2346";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}