$re = '/(\d*)(\d{1})/';
$str = '2346';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;