import Foundation
let pattern = #"(\d*)(\d{1})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2346"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)