use strict;
my $str = '2346';
my $regex = qr/(\d*)(\d{1})/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";