using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:name#(\w+?)\^)?(?:value#(\w+?)\^)?(?:quantity#(\d+?))?";
string input = @"Name#Size^Value#S^Name#Color^Value#Black^Quantity#2
Name#Size^Value#XXL^Quantity#3";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}