import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:name#(\\w+?)\\^)?(?:value#(\\w+?)\\^)?(?:quantity#(\\d+?))?";
final String string = "Name#Size^Value#S^Name#Color^Value#Black^Quantity#2\n"
+ "Name#Size^Value#XXL^Quantity#3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}