// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:name#(\w+?)\^)?(?:value#(\w+?)\^)?(?:quantity#(\d+?))?").unwrap();
let string = "Name#Size^Value#S^Name#Color^Value#Black^Quantity#2
Name#Size^Value#XXL^Quantity#3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}