#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?smx)(?(DEFINE)" & @CRLF & _
" (?<cut>" & @CRLF & _
" ^CUT-FROM-" & @CRLF & _
" (?&content)*?" & @CRLF & _
" ^CUT-TO" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" (?<content>" & @CRLF & _
" (?: (?!CUT-(?:FROM-|TO)) . )++" & @CRLF & _
" | (?&cut)" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"(?&cut)"
Local $sString = "CUT-FROM-A ..." & @CRLF & _
"CUT-FROM-B ..." & @CRLF & _
"CUT-TO ..." & @CRLF & _
"ignore" & @CRLF & _
"CUT-TO" & @CRLF & _
"apple" & @CRLF & _
"CUT-FROM-C ..." & @CRLF & _
"CUT-TO" & @CRLF & _
"orange" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")