package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?smx)(?(DEFINE)
(?<cut>
^CUT-FROM-
(?&content)*?
^CUT-TO
)
(?<content>
(?: (?!CUT-(?:FROM-|TO)) . )++
| (?&cut)
)
)
(?&cut)`)
var str = `CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
ignore
CUT-TO
apple
CUT-FROM-C ...
CUT-TO
orange
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}