const regex = /(?(DEFINE)
(?<cut>
^CUT-FROM-
(?&content)*?
^CUT-TO
)
(?<content>
(?: (?!CUT-(?:FROM-|TO)) . )++
| (?&cut)
)
)
(?&cut)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<cut>
^CUT-FROM-
(?&content)*?
^CUT-TO
)
(?<content>
(?: (?!CUT-(?:FROM-|TO)) . )++
| (?&cut)
)
)
(?&cut)', 'gsm')
const str = `CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
ignore
CUT-TO
apple
CUT-FROM-C ...
CUT-TO
orange
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}