import re
regex = re.compile(r"""
(?(DEFINE)
(?<cut>
^CUT-FROM-
(?&content)*?
^CUT-TO
)
(?<content>
(?: (?!CUT-(?:FROM-|TO)) . )++
| (?&cut)
)
)
(?&cut)
""", flags=re.DOTALL | re.MULTILINE | re.VERBOSE)
test_str = ("CUT-FROM-A ...\n"
"CUT-FROM-B ...\n"
"CUT-TO ...\n"
"ignore\n"
"CUT-TO\n"
"apple\n"
"CUT-FROM-C ...\n"
"CUT-TO\n"
"orange\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")