import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<cut>\n"
+ " ^CUT-FROM-\n"
+ " (?&content)*?\n"
+ " ^CUT-TO\n"
+ " )\n\n"
+ " (?<content>\n"
+ " (?: (?!CUT-(?:FROM-|TO)) . )++\n"
+ " | (?&cut)\n"
+ " )\n"
+ ")\n\n"
+ "(?&cut)";
final String string = "CUT-FROM-A ...\n"
+ "CUT-FROM-B ...\n"
+ "CUT-TO ...\n"
+ "ignore\n"
+ "CUT-TO\n"
+ "apple\n"
+ "CUT-FROM-C ...\n"
+ "CUT-TO\n"
+ "orange\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}