#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)(?<=\"compliantNotes\": \").*(?=\"\s+\"compliantDetected\":)"
Local $sString = ""compliantNotes": " this is" & @CRLF & _
"" & @CRLF & _
"the text I expect, works in Chrome, but not in IE" "compliantDetected": blah" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")