$re = '/(?<=\"compliantNotes\": \").*(?=\"\s+\"compliantDetected\":)/mis';
$str = '"compliantNotes": " this is
the text I expect, works in Chrome, but not in IE" "compliantDetected": blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);