const regex = /(?<=\"compliantNotes\": \").*(?=\"\s+\"compliantDetected\":)/gmis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\"compliantNotes\\": \\").*(?=\\"\\s+\\"compliantDetected\\":)', 'gmis')
const str = `"compliantNotes": " this is
the text I expect, works in Chrome, but not in IE" "compliantDetected": blah
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}